Siemens Dicom and .rda files cannot open

Home > Forums > jMRUI Software > General support > Siemens Dicom and .rda files cannot open

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #1423
    Harshal Patel

    Dear jMRUI Experts,

    I am trying to open Siemens dicom files and .rda files but unfortunately I cannot open it in jMRUI. It shows “loading….” and never loads either of the dataset. Could you please help me?? I would really appreciate you and be grateful to your whole team.


    Harshal Patel
    Aachen University Hospital


    Dear Harshal Patel,

    Please try to open your files with “Open As” from the main menu. Later select type of your file. Inform me about the results.

    Anahita Fathi

    Dear Michal Jablonski,

    I have encountered the same problem and I couldn’t solve it by using “Open As”. I have installed the latest Java version and also have set the Path. Yet I cannot open any files, as it shows “Loading files” and nothing happens.

    I appreciate if you could advise.

    Thank you

    Anahita Fathi
    Imam Khomini Hospital Complex

    Harshal Patel

    Dear Michal Jablonski,

    I have also confronted the same problem and I couldn’t solve it by using “Open As” as mentioned by Anahita in the previous comment. It shows “Loading files” and nothing happens :(.

    I would be grateful to you for any inputs/hints/suggestions.
    Kind regards,

    Harshal Patel
    Aachen University Hospital


    Dear Anahita Fathi and Harshal Patel

    Are you sure you installed 32bit Java?

    It looks like you have a 64b Java.



    I am a new user, and would like to look process some MRS data (dicom) retrieved from Siemens 3T Prisma System.
    I have a Windows 7 Enterprise 64-bit, and installed 32bit Java for JMRUI.
    When I open dcm files, it gives error and says “unable to read those files..”
    When I open files using ‘open as dicom’ it says: “com.pixelmed.dicom.DicomException: Spectroscopy data missing”…

    I corrected the path as indicated in readme file, though still gave the same errors.


    Asaf Gilboa


    I am running into trouble opening Siemens .dcm files.
    I am running jmrui-5.2 on linux red hat 64 bit. I installed the 32-bit java jdk1.8.0_20 and defined JAVA_HOME and JRE_HOME appropriately.
    I also installed the siemens update (though that was probably unnecessary):

    GE and Siemens format update

    The error I am receiving is:
    mrui.plugin.conversion.ConversionException: java.lang.UnsatisfiedLinkError: /2volatile/gilboa_lab/software/jmrui-5.2/lib/ /2volatile/gilboa_lab/software/jmrui-5.2/lib/ wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)



    Dear Asaf,

    You Java is not configured correctly, that’s why you’re getting:

    “class: ELFCLASS32 (Possible cause: architecture word width mismatch)”

    Please correct your Java installation (more in the manual)

    Dingyi Lin

    Hi, I ran into the same problem as you. Was your problem solved?

    Ralf Mekle


    I installed jMRUI_7.0.3 on a PC running Windows 10 (64-Bit) by extracting all files using the “Full Pathnames” option of the 7-Zip software. I also installed the free 32-bit JRE environment as recommended in the readme.txt file of jMRUI (here the version is bellsoft-jre20.0.2+10).

    I cannot open any Siemens DICOM (.IMA) MRS data generated on a Siemens PrismaFit with the software version VE11 installed.

    – Using ‘Open’ in jMRUI the error “30 Aug 2023 18:26:23 WARNING loadData WARNING – Bytes not read:142790” is issued.

    – Using ‘Open as’ and selecting ‘Siemens Dicom’ the error “mrui.plugin.conversion.ConversionException: Problem loading plugin” is issued.

    The JRE is enabled. Different unzipping options have not solved the problem. Only Siemens.rda MRS files can be opened right now.

    Any help would be greatly appreciated.

    Thanks a lot!

    Ralf Mekle
    Physikalisch-Technische Bundesanstalt (PTB) Berlin

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.